Kubernetes sérülékenysége
Angol cím: 
Kubernetes vulnerability
CERT-Hungary ID: 
CH-14529
Felfedezés dátuma: 
2018-12-06
Összefoglaló: 

A Kubernetes container menedzsment rendszer kritikus kockázati besorolású sérülékenysége vált ismertté, amit kihasználva a támadók emelt szintű jogosultsághoz juthatnak.

Leírás: 

Azok a felhasználók, akiknek van jogosultsága kapcsolatot létrehozni a Kubernetes API kiszolgálón keresztül a backend kiszolgálóhoz, egy speciálisan kialakított kérés segítségével tetszőleges kéréseket tudnak küldeni közvetlenül a backend kiszolgálónak ugyanazon a kapcsolaton keresztül. A kérések ugyanazon TLS hitelesítési adatokkal kerülnek végrehajtásra, amelyeket a Kubernetes API kiszolgáló használ a backend eléréséhez.

Megoldás: 
Frissítsen a legújabb verzióra
Érintett verziók: 
Kubernetes v1.0.x-1.9.x
Kubernetes v1.10.0-1.10.10
Kubernetes v1.11.0-1.11.4
Kubernetes v1.12.0-1.12.2