Hibás automatikus frissítési modul a WordPress 4.9.3-as verziójában

A WordPress fejlesztői nemrégiben kiadták a népszerű tartalomkezelő szoftver 4.9.3-as verzióját, amely egy hibás kód miatt lehetetlenné teszi, hogy az alkalmazás automatikusan frissítse saját magát. Ennek következtében megszakad a frissítési folyamat és a keretrendszer - hacsak kézzel nem frissítjük - mindig a régebbi verziójú marad, nyitva hagyva a lehetőséget a jövőben fellelhető esetleges biztonsági rések kihasználására. A hiba kizárólag a 4.9.3-as verziót érinti.


Mivel az automatikus frissítés a jövőben nem fog lefutni, ezért a GovCERT az alábbiak megtételét javasolja:

  • Nyissa meg a WordPress Dashboard → Updates menüpontot, és kattintson az “Update Now” lehetőségre!
  • Amennyiben van hozzáférésünk a WordPress-hez és a WP-CLI telepítve van, a wp core ugyanúgy frissül, mint korábban.
  • FTP letöltés esetén csak a wp-includes/update.php és wp-includes/version.php fájlok módosulnak.
  • Ha van parancssori hozzáférésünk, akkor php utasításokkal is meg lehet oldani a frissítést: php -r 'include "wp-load.php"; wp_maybe_auto_update();
Cikk
Szabad címkék